Issue with our site monitoring tool
Incident Report for Gengo
Resolved
Our site monitoring tool is showing checks in the Unkown state.

Pingdom incident details available here: https://status.pingdom.com/
Posted Jul 17, 2020 - 21:30 UTC