Issues with database
Incident Report for Gengo
Resolved
System is back to normal. Thank you for your patience. We are very sorry for the inconvenience.

We are still closely monitoring the situation and will keep you updated.
Posted Aug 23, 2020 - 17:20 UTC
Investigating
We are currently having issues with our database servers. We are aware of the situation and working on a fix.
Posted Aug 23, 2020 - 16:07 UTC
This incident affected: API (Translation API), Customer Pages (Order Form, Customer Dashboard), and Translator Tools (Translator Dashboard, Workbench, RSS).